IP-KRYPTO cipher machine for military use

Authors

DOI:

https://doi.org/10.26636/jtit.2004.4.263

Keywords:

IPsec standards, ITSEC evaluation criteria

Abstract

Polish military IP networks can be effectively and cheaply secured by IP-KRYPTO cipher machines which are developed in the Military Communication Institute. The cooperation with Polish manufacturers - Optimus and ABA Kraków and the usage of COTS elements and ideas speed up the research and development works. The IP-KRYPTO cipher machine will be used for securing the "SECRET" data so it must be certified to fulfill E3 ITSEC evaluation criteria. This requirement generates additional challenges in the development process when the COTS elements are to be implemented.

Downloads

Download data is not yet available.

References

[1] Thales "Cryptel-IP. The TCE 621 IP Crypto Device"
View in Google Scholar

[2] RFC 2401, "Security Architecture for the Internet Protocol".
View in Google Scholar

[3] RFC 2402, "IP Authentication Header".
View in Google Scholar

[4] RFC 2406, "Encapsulating Security Payload (ESP)".
View in Google Scholar

[5] RFC 2407, "Internet IP Security Domain of Interpretation for ISAKMP".
View in Google Scholar

[6] RFC 2409, "Internet Key Exchange (IKE)".
View in Google Scholar

[7] RFC 2412, "OAKLEY Key Determination Protocol".
View in Google Scholar

[8] "ITSEC evaluation criteria".
View in Google Scholar

Downloads

Submitted

2023-04-09

Published

2004-12-30

Issue

Section

ARTICLES FROM THIS ISSUE

How to Cite

[1]
M. Borowski and G. Łabuzek, “IP-KRYPTO cipher machine for military use”, JTIT, vol. 18, no. 4, pp. 64–68, Dec. 2004, doi: 10.26636/jtit.2004.4.263.